CYBERSECURITY RISK ALERT: GOOGLE CHROME VULNERABILITY

Recently, Google identified a zero-day vulnerability affecting Chrome internet browsers. The vulnerability is a memory management error which could allow a remote attacker to read the contents of files stored on a user’s computer. Google addressed the vulnerability in Chrome version 72.0.3626.121.

Check if your Chrome browser is up-to-date:

  • Click this icon in the upper right corner of your browser;
  • Go to ‘Help’;
  • Go to ‘About Google Chrome’;
  • Ensure that your browser displays version 72.0.3626.121

If your browser is not up-to-date, update it immediately.


For additional information, please visit: https://chromereleases.googleblog.com/2019/03/stable-channel-update-for-desktop.html